ClassDojo

Hi! It looks like you're using an older browser. ClassDojo requires Chrome, Firefox, or Internet Explorer 9 and above to run. You can upgrade Internet Explorer, download Chrome, or download Firefox.

Older browsers don't security features we need to make sure that your data is safe. Check out our Privacy Center for more information about how we keep ClassDojo safe and secure. :)

Teacher
School Leader